re = /((?:<p|\G(?!^))(?:(?!<\/p|<\s*\/?\s*br).)*)<\s*\/?\s*br\s*\/?\s*>/
str = 'These 2 lines should not be<br/>
touched. Example only.<br/><br/>
<pre class="code">mysql>
<strong> SELECT state, COUNT(*) FROM president GROUP BY state;</strong><br/>
+-------+----------+<br/>
| state | COUNT(*) |<br/>
+-------+----------+<br/>
| OH | 7 |<br/>
| PA | 1 |<br/>
| SC | 1 |<br/>
| TX | 2 |<br/>
| VA | 8 |<br/>
| VT | 2 |
+-------+----------+
sdfsdf<br>
< /pre>
sdfsdf<br>
</pre>
kshdkjfkjshdf<br>
<p><br></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end