#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[#@](?![\s\S]*[#@])"
Local $sString = "@foo #foo@foo@foo #foo" & @CRLF & _
"foofoofoo" & @CRLF & _
"foo @bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")