// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http|ftp|https):\/\/([\w_-]+(?:(?:\.[\w_-]+)+))([\w.@,^%:\/~+#-]+)([?][\w@?^=%&\/~+#-]+)+").unwrap();
let string = "Click Here http://www.kolishcool.mobi/mobileportal/auth?c=27&u=3422746&tn=533e7ab1374efa7c5ef3645ccf2a45043d884704510a";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}