$re = '/\A\d?[a-zA-Z]{1,2}\d{1,4}[a-zA-Z]{1,3}\Z/';
$str = 'AE0MW';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);