package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^#([a-zA-Z0-9 ]*) : ([a-zA-Z0-9 ]*)$`)
var str = `#Property Name : Property Value`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}