$re = '/^.*?\d/m';
$str = 'DitchMe5KeepMe
Dit5chMe5KeepMe';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;