$re = '/^(([\d]{1,2})\:){1,2}([\d]{2})$/m';
$str = '01:04:06
1:04:06
04:06
4:06';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);