import Foundation
let pattern = #"Me llamo ([A-z]{3,}), tengo (\d{1,3}) años y vivo en ([A-z]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Me llamo Luis, tengo 29 años y vivo en Valencia y me gusta el deporte.
Hola, me llamo Ana, tengo 30 años y vivo en Valencia.
Me llamo Carlos, tengo 40 años y vivo en Madrid.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)