# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\\])(fun)/\1\\fun/gm;t' <<< "Czterdzieści [tex]fun{4}\fun{5}fun{6}[/tex] lat minęło"