#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^\\])(fun)"
Local $sString = "Czterdzieści [tex]fun{4}\fun{5}fun{6}[/tex] lat minęło"
Local $sSubst = "\1\\fun"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)