use strict;
my $str = 'Czterdzieści [tex]fun{4}\\fun{5}fun{6}[/tex] lat minęło';
my $regex = qr/([^\\])(fun)/mp;
my $subst = '\\1\\\\fun';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";