re = /([^\\])(fun)/m
str = 'Czterdzieści [tex]fun{4}\\fun{5}fun{6}[/tex] lat minęło'
subst = '\\1\\\\fun'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result