re = /^\d+([\ _.,])?\d*(?:\1\d+)*$/m
str = '1
1234
3.14159
12_456_789
123.456.789.0
123,456.789_987'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end