re = /(?:(?!bread).)*(?:bread(.*)bread)?.*/
str = 'breadjambread'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result