$re = '~(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d)~i';
$str = 'new stackoverflow 244code 7490script design';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;