use strict;
my $str = '850 7th Ave Frnt 1, New York, NY 10019';
my $regex = qr/\b\d+\b/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";