import Foundation
let pattern = #"^([a-zA-Z0-9])*(\s|_)(__IMG__\d{4}_\d{2}_\d{2}__\d{2}_\d{2}_\d{2}_\d{3}|PXL_\d{8}_\d{9})(\.capture|heic|jpg])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abcde PXL_20230711_210613237.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}