$re = '/^interface\b.*(?:\r?\n(?!=).*)*/m';
$str = '======
interface And
public void and(int, int);
public void nand(int, int);
======
interface Or
public void or(int, int); public void nor(int, int);
======
interface Xor
public void xor(int, int); public void xnor(int, int);
======
interface Not
public void not(int);
======
class BitWise extends And, Or, Xor, Not
// Implementation of the Interfaces goes here
======
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);