#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)^interface\b.+?(?=\r?\n=)"
Local $sString = "======" & @CRLF & _
"" & @CRLF & _
"interface And" & @CRLF & _
"" & @CRLF & _
"public void and(int, int);" & @CRLF & _
"" & @CRLF & _
"public void nand(int, int);" & @CRLF & _
"" & @CRLF & _
"======" & @CRLF & _
"" & @CRLF & _
"interface Or" & @CRLF & _
"" & @CRLF & _
"public void or(int, int); public void nor(int, int);" & @CRLF & _
"" & @CRLF & _
"======" & @CRLF & _
"" & @CRLF & _
"interface Xor" & @CRLF & _
"" & @CRLF & _
"public void xor(int, int); public void xnor(int, int);" & @CRLF & _
"" & @CRLF & _
"======" & @CRLF & _
"" & @CRLF & _
"interface Not" & @CRLF & _
"" & @CRLF & _
"public void not(int);" & @CRLF & _
"" & @CRLF & _
"======" & @CRLF & _
"" & @CRLF & _
"class BitWise extends And, Or, Xor, Not" & @CRLF & _
"" & @CRLF & _
"// Implementation of the Interfaces goes here" & @CRLF & _
"" & @CRLF & _
"======" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")