package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d\s?\d\s?\d`)
var str = `150 EUR 15 000 EUR 150 150 EUR 1 500 EUR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}