const regex = /\b\d{5,}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{5,}\\b', 'g')
const str = `We’re in 2014, but this number is not 5-digits long. However, 20145 is matched, like 345421234 but not a425234 nor 123455x.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}