$re = '/(?>((\d)\2)(?!.*\1)){3}$/';
$str = '03334112233';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);