#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ":(.*?)\(?"
Local $sString = "virtual void NameSpace1::NameSpace2::ClassName1::function_name1(int arg1) const" & @CRLF & _
"void function_name2" & @CRLF & _
"void NameSpace2::NameSpace4::ClassName2::function_name3" & @CRLF & _
"function_name4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")