re = /:(.*?)\(?/
str = 'virtual void NameSpace1::NameSpace2::ClassName1::function_name1(int arg1) const
void function_name2
void NameSpace2::NameSpace4::ClassName2::function_name3
function_name4'
# Print the match result
str.match(re) do |match|
puts match.to_s
end