# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:(.+?):/<img src="http:\/\/2ch.eq\/src\/$1.jpg" \/>/g;t' <<< "blabla :KOKO: blabla :YOBA: bla"