package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:(.+?):`)
var str = `blabla :KOKO: blabla :YOBA: bla`
var substitution = "<img src="http://2ch.eq/src/$1.jpg" />"
fmt.Println(re.ReplaceAllString(str, substitution))
}