const regex = /:(.+?):/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':(.+?):', 'g')
const str = `blabla :KOKO: blabla :YOBA: bla`;
const subst = `<img src="http://2ch.eq/src/$1.jpg" />`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);