const regex = /^(?:\d{4,5}\w{0,2}(?:\.\w{1,2})?|\w{3}-\d{6})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{4,5}\\w{0,2}(?:\\.\\w{1,2})?|\\w{3}-\\d{6})$', 'gm')
const str = `00000
00000.0
00000.00
00000.X
000000
000000X
00000X
00000X.0
00000X.0X
00000X0.0
00000XX.0
0000X.0
XXX-000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}