# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(?:template\s*<\w+>\s+)?(?:(const|mutable|static|friend|unsigned)\s+)*\w+(::\w+)?(<([\w<> *&,()]|::)+>)?(,?\s+\*?\w+( = (-?\d+(\.\d+)?|((QMap|QList)<[^()]+>\(\))|(\w+::)*\w+(\([^()]+\))?)|\[\d+\])?)+;"
test_str = (" FilterType mFilter = FilterNone;\n"
" QgsRectangle mFilterRect;\n"
" QgsFeatureId mFilterFid = -1;\n"
" QgsFeatureIds mFilterFids;\n"
" std::unique_ptr< QgsExpression > mFilterExpression;\n"
" QgsExpressionContext mExpressionContext;\n"
" Flags mFlags;\n"
" QgsAttributeList mAttrs;\n"
" QgsSimplifyMethod mSimplifyMethod;\n"
" long mLimit = -1;\n"
" OrderBy mOrderBy;\n"
" InvalidGeometryCheck mInvalidGeometryFilter = GeometryNoCheck;\n"
" std::function< void( const QgsFeature & ) > mInvalidGeometryCallback;\n"
"static QHash<QString, Help> sFunctionHelpTexts;\n"
"friend class QgsOgcUtils;\n"
"template<typename> friend class QgsAbstractFeatureIteratorFromSource;\n"
"const QgsAbstractGeometry *mGeometry = 0;\n"
"mutable unsigned char *mP;\n"
"QgsPoint mEdgePoints[2];\n"
"double xxxx, yyyyy;\n\n"
"QgsProviderRegistry::WidgetMode mWidgetMode = QgsProviderRegistry::WidgetMode::None;\n\n"
" \n"
"QMap<QTreeWidgetItem *, QPair<QBrush, QBrush>> mTreeInitialStyle = QMap<QTreeWidgetItem *, QPair<QBrush, QBrush>>();\n"
" QMap<QTreeWidgetItem *, bool> mTreeInitialExpand = QMap<QTreeWidgetItem *, bool>();\n"
"QList<x> myList = QList<x>();\n\n\n"
"SHOULD NOT MATCH\n"
"virtual bool filterAcceptsRow( int row, const QModelIndex &source_parent ) const;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.