#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)# header 1(?:[^#]*|(?!# header 2)#)*"
Local $sString = "# header 1" & @CRLF & _
"Lorem ipsum" & @CRLF & _
"" & @CRLF & _
"# random header" & @CRLF & _
"dolor si" & @CRLF & _
"" & @CRLF & _
"# header 2" & @CRLF & _
"loram ipsum"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")