using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# header 1(?:[^#]*|(?!# header 2)#)*";
string input = @"# header 1
Lorem ipsum
# random header
dolor si
# header 2
loram ipsum";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}