using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[(\?|\&)]([^=]+)\=([^&#]+)";
string input = @"https://www.google.com/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=document.location";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}