package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.+?)/([\w]+\.log)$`)
var str = `/var/log/xyz/10032008.log`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}