using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^/]|^)(www)";
string substitution = @"$1http://$2";
string input = @"www.ni@gmail.com""
www.google.com find me on this www.somethin.com
http://www.google.com
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}