const regex = /\b(10|11|12)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(10|11|12)\\b', 'g')
const str = `10 34 12 11 200 110 22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}