# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$plugins\.(\w+)\.(.+)/plugins.\1.process_conditions.variabilities.\2/;t' <<< "$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb"