using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$plugins\.(\w+)\.(.+)";
string substitution = @"plugins.\1.process_conditions.variabilities.\2";
string input = @"$plugins.official.random_hsv_color_as_rgb.RandomHsvColorAsRgb";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}