import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "chipmunk(?=[^\\)\\(\\\\]*(?:\\\\.[^\\)\\(\\\\]*)*\\))";
final String string = "bar(alvin the chipmunk dude)\n"
+ "chipmunk(alvin the chipmunk dude)\n\n"
+ "I want to replace \"chipmunk\" on the first only (bar), could also be foo or any other beginning.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}