$re = '/chipmunk(?=[^\)\(\\\\]*(?:\\\\.[^\)\(\\\\]*)*\))/';
$str = 'bar(alvin the chipmunk dude)
chipmunk(alvin the chipmunk dude)
I want to replace "chipmunk" on the first only (bar), could also be foo or any other beginning.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);