re = /chipmunk(?=[^\)\(\\]*(?:\\.[^\)\(\\]*)*\))/
str = 'bar(alvin the chipmunk dude)
chipmunk(alvin the chipmunk dude)
I want to replace "chipmunk" on the first only (bar), could also be foo or any other beginning.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end