import Foundation
let pattern = #"chipmunk(?=[^\)\(\\]*(?:\\.[^\)\(\\]*)*\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
bar(alvin the chipmunk dude)
chipmunk(alvin the chipmunk dude)
I want to replace "chipmunk" on the first only (bar), could also be foo or any other beginning.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)