package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\[](@[a-zA-Z0-9\.\-]+)`)
var str = `Hey @first.last tell [@first.last] to check this out`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}