const regex = /(?:\s+|^)\S*(?<!\w)(?:https?|<filter>)(?!\w)\S*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s+|^)\\S*(?<!\\w)(?:https?|<filter>)(?!\\w)\\S*', 'g')
const str = ` hello, my name is James.
John 30 hello, my name is John. Here is my favourite website https://stackoverflow.com
Jim 27 Hi! I'm another persoon whose name begins with a J! Here is something that should be filtered out: <filter>
Do not filter anything when <filter or word<filter>word is present`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}