import re
regex = re.compile(r"[0-9]*\.[0-9]+\.[0-9]+\.[0-9]")
test_str = ("\n\n"
"Interface IP-Address OK? Method Status Protocol\n"
"TenGigabitEthernet1/1 unassigned YES NVRAM up up\n"
"Te1/1.200 216.254.132.249 YES NVRAM up up\n"
"Te1/1.201 10.201.120.173 YES NVRAM up up\n"
"TenGigabitEthernet1/2 10.201.121.46 YES NVRAM up up\n"
"TenGigabitEthernet1/3 unassigned YES NVRAM up up\n"
"Te1/3.905 198.32.160.89 YES NVRAM up up\n"
"Te1/3.908 206.130.10.3 YES NVRAM up up\n"
"TenGigabitEthernet1/4 unassigned YES NVRAM administratively down down\n"
"TenGigabitEthernet1/5 unassigned YES NVRAM up up\n"
"Te1/5.98 216.254.131.1 YES NVRAM up up\n"
"Te1/5.100 216.254.130.129 YES NVRAM administratively down down\n"
"Te1/5.106 216.254.130.158 YES NVRAM administratively down down\n"
"Te1/5.110 216.254.131.149 YES NVRAM up up\n"
"Te1/5.111 216.254.131.117 YES NVRAM up up\n"
"Te1/5.132 216.254.130.25 YES NVRAM administratively down down\n"
"Te1/5.134 216.254.130.29 YES NVRAM up up\n"
"Te1/5.205 216.254.141.153 YES NVRAM up up\n"
"TenGigabitEthernet1/6 unassigned YES NVRAM up down\n"
"TenGigabitEthernet1/7 unassigned YES NVRAM up up\n"
"Te1/7.907 198.32.118.14 YES NVRAM up up\n"
"TenGigabitEthernet1/8 10.201.121.154 YES NVRAM up up\n"
"GigabitEthernet2/1 unassigned YES unset up up\n"
"GigabitEthernet2/2 unassigned YES unset administratively down down\n"
"GigabitEthernet2/3 unassigned YES unset administratively down down\n"
"GigabitEthernet2/4 unassigned YES unset up up\n"
"GigabitEthernet2/5 unassigned YES unset administratively down down\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")