package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[+-]?((\\d+(\\.\\d*)?)|(\\.\\d+))$`)
var str = `-0.2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}