using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\W)([0-9]+_[a-zA-Z0-9])\w+";
string input = @"A1_aaa123
9_1aa123
A_aaa12
1_aa123
1_jjj112
2_aslk
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}