import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"|'[^'\\\\]*(?:\\\\.[^'\\\\]*)*')|/\\*[^*]*\\*+(?:[^/*][^*]*\\*+)*/|//.*[\\r\\n]*";
final String string = "random text\n"
+ "/* removable comment */\n"
+ "\"but /* never remove this */ one\"\n"
+ "'but /* never remove this */ one either'\n"
+ "// Text here\n"
+ "more random *text*\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}