const regex = new RegExp('("[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|\\'[^\\'\\\\]*(?:\\\\.[^\\'\\\\]*)*\\')|/\\*[^*]*\\*+(?:[^/*][^*]*\\*+)*/|//.*[\\r\\n]*', 'g')
const str = `random text
/* removable comment */
"but /* never remove this */ one"
'but /* never remove this */ one either'
// Text here
more random *text*
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);