import Foundation
let pattern = #"("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')|/\*[^*]*\*+(?:[^/*][^*]*\*+)*/|//.*[\r\n]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
random text
/* removable comment */
"but /* never remove this */ one"
'but /* never remove this */ one either'
// Text here
more random *text*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)