re = /^(([a-zA-Z]:)|(\\{2}\w+)\$?)(\\(\w[\w].*))+(.jpeg|.JPEG|.jpg|.JPG)$/m
str = 'A:\\12anything.JPEG
\\\\1$\\anything.jpg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end